Chapter 9
Table Analysis

Chapter Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>179</td>
</tr>
<tr>
<td>Association in a $2 \times 2$ Table</td>
<td>181</td>
</tr>
<tr>
<td>Exact Test</td>
<td>187</td>
</tr>
<tr>
<td>Association in Sets of Tables</td>
<td>193</td>
</tr>
<tr>
<td>Observer Agreement</td>
<td>201</td>
</tr>
<tr>
<td>References</td>
<td>206</td>
</tr>
</tbody>
</table>
Chapter 9
Table Analysis

Introduction

Often you need to analyze the information in a table, sometimes called a contingency table or a crossclassification table. You may analyze a single table, or you may analyze a set of tables. You are also often concerned with evaluating the presence of association in a table, or whether there is some sort of relationship between the variable determining the rows of the table and the variable determining the columns of the table. If there is an inherent ordering in the rows or columns of the table, the association may be linear. Various chi-square statistics such as the Pearson chi-square and the likelihood ratio chi-square are used to assess association.

Figure 9.1. Table Analysis Selection Menu
Besides assessing the presence of association, you may also be interested in computing a measure of association, or a statistic that provides some understanding of the strength of the association. The odds ratio is a standard measure of association often used in medical and epidemiological studies.

Using the Table Analysis task, not only can you analyze a single table, but you can also analyze sets of tables. This provides a way to control, or adjust for, a covariate, while assessing association of the rows and columns of the tables. Extended Mantel-Haenszel statistics, also called Cochran-Mantel-Haenszel statistics, provide a way to utilize all the information in the constituent tables in a test for the hypothesis of association. Tables may also contain information from observer agreement studies in which the evaluations or assessments of two different observers are collected. Statistics called measures of agreement assess how closely the observers agree.

The Table Analysis task provides chi-square tests of association for the $r \times c$ table, including statistics such as the Pearson chi-square and likelihood ratio test, and it also computes extended Mantel-Haenszel tests for sets of tables. Fisher’s exact test can be computed for both the $2 \times 2$ and $r \times c$ table. In addition, the Table Analysis task also provides measures of association such as the odds ratio and relative risk for the $2 \times 2$ table as well as gamma, tau-b, Somer’s $D$, and the Pearson and Spearman correlation coefficients. In addition, you can obtain measures of agreement such as the kappa coefficient and the weighted kappa coefficient. McNemar’s test is produced for the $2 \times 2$ table.

The examples in this chapter demonstrate how you can use the Analyst Application to analyze tables, including assessing the presence of association in a table and sets of tables and assessing observer agreement.
Association in a $2 \times 2$ Table

The most basic table is a $2 \times 2$ table. Usually, the columns represent some sort of outcome, often yes or no, and the rows represent levels of a factor that may influence the outcome. Suppose, for example, that researchers were investigating the properties of a new “ouchless” bandaid for children. Interest lies in whether those children trying the test bandaid recorded fewer complaints on removal than those children using a regular bandaid. You can address this question by forming the two-way table of bandaid type and complaint status and then assessing the association between the rows and columns of that table.

Open the Bandaid Data Set

These data are provided as the Bandaid data set in the Analyst Sample Library. To open the Bandaid data set, follow these steps:

1. Select Tools $\rightarrow$ Sample Data $\ldots$
2. Select Bandaid.
3. Click OK to create the sample data set in your Sasuser directory.
4. Select File $\rightarrow$ Open By SAS Name $\ldots$
5. Select Sasuser from the list of Libraries.
6. Select Bandaid from the list of members.
7. Click OK to bring the Bandaid data set into the data table.

Figure 9.2 displays the data table containing these data. Note that the data are in frequency form, with the variable count containing the frequencies of the profile contained in each row of the table. The variable type is the type of bandaid tested and the variable outcome is the status of complaints.
Chapter 9. Table Analysis

Specify the Table
To construct the appropriate two-way table and request tests of association, follow these steps:

1. Select Statistics → Table Analysis . . .
2. Select type from the candidate list as the Row variable.
3. Select outcome from the candidate list as the Column variable.
4. Select count from the candidate list as the Cell Counts variable.

Figure 9.3 displays the resulting dialog.

<table>
<thead>
<tr>
<th></th>
<th>type</th>
<th>outcome</th>
<th>count</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>regular</td>
<td>complain</td>
<td>14</td>
</tr>
<tr>
<td>2</td>
<td>regular</td>
<td>no</td>
<td>16</td>
</tr>
<tr>
<td>3</td>
<td>test</td>
<td>complain</td>
<td>10</td>
</tr>
<tr>
<td>4</td>
<td>test</td>
<td>no</td>
<td>30</td>
</tr>
</tbody>
</table>

Figure 9.2. Data Set Bandaid in the Data Table
Figure 9.3. Table Analysis Task for Bandaid Study

Request Tests and Measures of Association

By selecting the rows and columns of the table, you have requested the construction of a $2 \times 2$ table. To request chi-square tests of association and the odds ratio, which is a measure of association, follow these steps:

1. Click on the Statistics button.
2. Select Chi-square statistics.
3. Select Measures of association.
4. Click OK.

Figure 9.4 displays the Statistics dialog.
Chapter 9. Table Analysis

Finally, in order to customize the form of the displayed table, follow these steps:

1. Click on the Tables button.
2. Select Observed under Frequencies.
3. Select Row under Percentages.
4. Click OK.

Figure 9.5 displays the resulting Tables dialog.
This requests that only the raw frequencies and the row percentages be listed in the printed table cell.

Click OK in the Table Analysis dialog to perform the analysis.

**Review the Results**

The frequency table is displayed in Figure 9.6. Note that 46 percent of those children getting regular bandaids had complaints about irritation when their bandaid was removed, compared to 25 percent of those children receiving the test bandaid.

**Figure 9.6.** Frequency Table for Bandaid Data

Figure 9.7 contains the table of computed chi-square statistics for this table. The Pearson chi-square statistic, labeled “Chi-Square,” has a value of 3.57 and an associated \( p \)-value of 0.0588 with 1 degree of freedom. If you were doing strict hypothesis testing, you would not reject the hypothesis of no association at the \( \alpha = 0.05 \) level of significance. However, researchers in this case found enough evidence in this pilot study to continue looking into the new product.
Figure 9.7. Chi-Square Statistics for Bandaid Data

Several other chi-square statistics also appear in this output, such as the likelihood ratio chi-square and the Mantel-Haenszel chi-square. These statistics are asymptotically equivalent.

Figure 9.8. Odds Ratio for Bandaid Data

Figure 9.8 contains the table of relative risk estimates including the odds ratio, which is labeled “Case-Control.” The odds ratio is the ratio of the odds of having an outcome for one group versus another.
When the odds ratio has the value 1, you have equal odds of having the outcome. When the odds ratio is greater than 1, one group has greater odds of an outcome than the other.

The odds ratio has a value of 2.62, which means that the odds of a complaint are 2.62 times higher for those children using the regular bandaid than for those using the test bandaid.

**Exact Test**

You may have noticed that the preceding statistical output also included a test called Fisher’s Exact test. When the sample size for the test of association of a table does not meet the usual guidelines (generally 20-25 total observations for a $2 \times 2$ table, with 80 percent of the table cells having counts greater than 5), an exact test may be a useful strategy.

The following data illustrate where an exact test may be appropriate. A marketing research firm took a sample of members at a health club and asked them a series of questions. They were interested in gathering information that could help their clients decide on audiences to target for new magazines. One of the questions was what activity the member considered his or her primary activity at the club. Another question was whether the member was considering making a major diet change. The researchers were interested in what types of sports magazines in which to place ads for a new food and nutrition magazine.

**Open the Gym Data Set**

These data are provided as the Gym data set in the Analyst Sample Library. To open the Gym data set, follow these steps:

1. Select **Tools → Sample Data** …
2. Select Gym.
3. Click **OK** to create the sample data set in your Sasuser directory.
4. Select **File → Open By SAS Name** …
5. Select Sasuser from the list of Libraries.
6. Select Gym from the list of members.

7. Click OK to bring the Gym data set into the data table.

Figure 9.9 displays the data table containing these data. Note that
the data are in frequency form, with the variable count containing
the frequencies of the profile contained in each row of the table. The
variable activity contains the type of activity, which can be aero-
bics, yoga, weightlifting, team sports such as volleyball and basket-
ball leagues, and cross-training. The variable DietChange indicates
whether the member was contemplating a change in diet.

<table>
<thead>
<tr>
<th>Gym (Browse)</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>activity</td>
<td>DietChange</td>
<td>count</td>
</tr>
<tr>
<td>1</td>
<td>aerobics</td>
<td>yes</td>
</tr>
<tr>
<td>2</td>
<td>aerobics</td>
<td>no</td>
</tr>
<tr>
<td>3</td>
<td>yoga</td>
<td>yes</td>
</tr>
<tr>
<td>4</td>
<td>yoga</td>
<td>no</td>
</tr>
<tr>
<td>5</td>
<td>weights</td>
<td>yes</td>
</tr>
<tr>
<td>6</td>
<td>weights</td>
<td>no</td>
</tr>
<tr>
<td>7</td>
<td>team</td>
<td>yes</td>
</tr>
<tr>
<td>8</td>
<td>team</td>
<td>no</td>
</tr>
<tr>
<td>9</td>
<td>cross</td>
<td>yes</td>
</tr>
<tr>
<td>10</td>
<td>cross</td>
<td>no</td>
</tr>
</tbody>
</table>

**Figure 9.9.** Data Set Gym in the Data Table

**Specify the Table**

To construct the appropriate two-way table and request tests of asso-
ciation, follow these steps:

1. Select Statistics → Table Analysis . . .

2. Select activity from the candidate list as the Row variable.

3. Select DietChange from the candidate list as the Column
   variable.

4. Select count from the candidate list as the Cell Counts vari-
   able.

Figure 9.10 displays the resulting dialog.
**Request Tests and Measures of Association**

By selecting the rows and columns of the table, you have requested the construction of a $5 \times 2$ table. To request chi-square tests of association, follow these steps:

1. Click on the **Statistics** button.
2. Select **Chi-square statistics**.
3. Click **OK**.

Note that the Tables dialog specifications (see Figure 9.5) made in the previous analysis remain in effect. Therefore, both frequencies and row percentages are produced for this analysis.

Click **OK** in the Table Analysis dialog to perform the analysis.

**Review the Results**

The frequency table is displayed in Figure 9.11. Note that 62 percent of those members participating in aerobics were considering a diet change and so were 60 percent of yoga practitioners. Eighty-six percent of those members lifting weights were not considering a diet change. Of those members playing a team sport or who considered themselves cross-trainers, the majority of members were not considering a diet change, but not by a wide margin.
Figure 9.11. Frequency Table for Gym Data

Figure 9.12 contains the table of chi-square statistics computed for this table. The Pearson chi-square statistic has a value of 11.4993 and an associated $p$-value of 0.0215 with 4 degrees of freedom. If you were doing strict hypothesis testing, you would reject the hypothesis of no association at the $\alpha = 0.05$ level of significance. However, if you look at Figure 9.11, you see that three table cells have a count of less than 5, which violates one of the sample size guidelines for the asymptotic tests. Thus, you may want to compute the exact test for these data.
Request the Exact Test

To request the exact test, simply return to the Table Analysis task and open the Statistics dialog. All of the settings you have previously selected for the table analysis are still in place. You need only request the additional exact test.

1. Select Statistics → Table Analysis …
2. Click on the Statistics button.
3. Select Exact test for (r × c) table.
4. Click OK.
5. Click OK in the main Table Analysis dialog to perform the analysis.
Figure 9.13. Statistics Dialog

Figure 9.13 displays the resulting dialog. Notice the warning that exact test computations may take an excessive amount of time. This would not be the case with very small cell counts, but it is an issue for other tables.

**Review the Results**

Figure 9.14 contains the results of this analysis, including the exact test results.
Figure 9.14. Exact Test Results

The exact test computes a $p$-value of 0.0139; thus, this test also results in the rejection of the hypothesis of no association in this table. There is some kind of association between the rows of the table and the columns of the table; type of primary activity made a difference in whether members were considering diet changes. Not only does degree of association seem to vary, but so does the direction. The market research company may end up suggesting that sports and fitness magazines be targeted in different ways for the new food and diet magazine ad campaign.

Association in Sets of Tables

After the pilot study on the new ouchless band aids, the investigators decided to continue their research by conducting a clinical trial in which children at five clinics were tested with the test and regular band aids. Instead of a single table, the clinical trial produces five tables. In order to assess whether the test band aids produced fewer complaints than the regular band aids, you need to assess the association in sets of tables instead of the association in a single table.
Extended Mantel-Haenszel statistics, also known as Cochran-Mantel-Haenszel statistics, provide a way of assessing association between two variables that determine a table while controlling for, or adjusting for, the variables that determine the sets of tables. These variables are also known as stratification variables. In this instance, the statistics can provide a way to assess the association between bandaid type and complaint status while controlling for clinic.

In the first section, the odds ratio was presented as a measure of association. You can also compute an overall odds ratio for a set of tables that has been adjusted for the stratification variables.

The Studybandaid data set contains the information collected in this clinical trial and includes data that constitute tables for each of the five clinics.

Open the Studybandaid Data Set

These data are provided as the Studybandaid data set in the Analyst Sample Library. To open the Studybandaid data set, follow these steps:

1. Select Tools → Sample Data . . .
2. Select Studybandaid.
3. Click OK to create the sample data set in your Sasuser directory.
4. Select File → Open By SAS Name . . .
5. Select Sasuser from the list of Libraries.
6. Select Studybandaid from the list of members.
7. Click OK to bring the Studybandaid data set into the data table.

Figure 9.15 displays the data table containing these data. Note that the data are in frequency form, with the variable count containing the frequencies of the profile contained in each row of the table. The column corresponding to the variable clinic contains the values for the five clinics.
Figure 9.15. Data Set Studybandaid in the Data Table

Specify the Tables

To request individual table tests of association as well as the CMH tests for the association of type of bandaid with complaint outcome, first specify the tables under study.

1. Select Statistics → Table Analysis . . .
2. Select type from the candidate list as the Row variable.
3. Select outcome from the candidate list as the Column variable.
4. Select clinic from the candidate list as the Strata variable.
5. Select count from the candidate list as the Cell Counts variable.

Figure 9.16 displays the resulting dialog.
Table Analysis: Study Bandaid

![Table Analysis Dialog Box]

**Figure 9.16.** Table Analysis Task for Bandaid Study

**Request Tests and Measures of Association**

Use the Statistics dialog to specify the tests.

1. Click on the Statistics button.
2. Select Chi-square statistics.
4. Click OK.

Note that the Tables dialog specifications (see Figure 9.5) made previously remain in effect. Therefore, both frequencies and row percentages are produced for this analysis.

Click OK in the Table Analysis dialog to perform the analysis.

**Review the Results**

The results produced include individual tables, individual table statistics, and the summary chi-square statistics.

Figure 9.17 contains the frequency table for clinic A. Figure 9.18 contains the table statistics for clinic A. The Pearson chi-square statistic has the value 2.8505 and a $p$-value of 0.091 with 1 degree of freedom.
Figure 9.17. Frequency Table for Clinic A

Figure 9.18. Table Statistics for Clinic A

Figure 9.19 contains the frequency table for clinic B. Figure 9.20 contains the associated table statistics. The Pearson chi-square statistic has a value of 9.9475 and a corresponding \( p \)-value of 0.0016.
The other individual tables, not printed here, show varying degrees of evidence of association. Clinic C and clinic E appear to have no evidence of association, while clinic D does appear to show evidence of association.
Figure 9.21 displays the results of the CMH analysis.

![Table Analysis of Studybandaid](image)

**Figure 9.21. CMH Summary Table**

Three versions of the CMH statistic are printed; all have the value 14.2206 and a p-value of 0.0002 with 1 degree of freedom. Your choice of statistic depends on the scale of variables that determine the rows and columns. The General Association statistic always applies. If the columns can be considered ordered, or ordinal, then the Row Mean Score statistic is appropriate as well and is directed at location shifts. If both the columns and rows are ordered, then the Correlation statistic is also appropriate and is directed at linear association. The degrees of freedom of these statistics vary. For more details, refer to Stokes, Davis, and Koch (1995). Note that the sample size requirement for the CMH statistics is that the total (tables combined) sample size be adequate.

In the case of the $2 \times 2$ table, all of these statistics are equivalent. Here, you can conclude that type of bandaid is significantly associated with complaint status, controlling for clinic. Figure 9.22 displays the overall relative risk and odds ratios and their confidence bounds.
Chapter 9. Table Analysis

Figure 9.22. Odds Ratio

The odds ratio for this study has the value 2.1597 with a confidence bound of (1.4420, 3.2348). This means that those children with the regular bandaid are twice as likely to have complaints as those with the test bandaid or, conversely, that those children with the test bandaid are half as likely to have complaints as those children with the regular bandaid. Since the 95 percent confidence bounds don’t include the value 1, this odds ratio is considered to be significantly different from 1.

Note that another test called the Breslow-Day test for Homogeneity of Odds Ratio is also printed. Since the test has a $p$-value of 0.3455, you would conclude that the hypothesis is not rejected. The sample size requirement for this test is that each individual table has to have sufficient sample size unlike the sample size requirement for the CMH statistics. In this case, since all tables have totals greater than 25, this condition is met.
Observer Agreement

Often, the data represented by a contingency table represents information collected in a study on observer agreement. There may be interest in gathering information on observer error, and such a study may be done as part of testing new processes, training, or tools. Sometimes different observers are studied, and sometimes the same observer is studied at different times or under different conditions.

The members of a northeastern music association were revising their system of conducting local and state-wide high school piano competitions. Instead of using local musicians as judges, they wanted to see if they could proceed more fairly by using one of two trained judges in conjunction with local judges, with whom they needed to come to consensus. In order to see how closely the trained judges match, they did an observer agreement study using some college music students after a training session. Twenty students played one of their current pieces, and both judges rated the performance as good, skilled, or superior.

In order to analyze such data, you form the table with the ratings of one rater forming the rows of the table and the ratings of the other rater forming the columns of the table. The cells of the table are the number of students who fell into the profiles composed of the combination of both ratings. Since there are 3 outcomes, there are 9 possible combinations as represented by the cells of a two-way table. Statistics called measures of agreement are then used to assess the degree of agreement.

Open the Piano Data Set

The Piano data set contains the variables Rater1 and Rater2 as well as a frequency variable count. These data are provided as the Piano data set in the Analyst Sample Library. To open the Piano data set, follow these steps:

1. Select Tools → Sample Data . . .
2. Select Piano.
3. Click OK to create the sample data set in your Sasuser directory.
4. Select **File → Open By SAS Name** . . .
5. Select **Sasuser** from the list of **Libraries**.
6. Select **Piano** from the list of members.
7. Click **OK** to bring the Piano data set into the data table.

Figure 9.23 displays the data table containing these data. Note that the data are in frequency form, with the variable **count** containing the frequencies of the profile contained in each row of the table. The variable **Rater1** contains the first rater's evaluations and the variable **Rater2** contains the second rater's evaluations.

![Piano table](image)

**Figure 9.23.** Data Set Piano in the Data Table

**Specify the Table**

To construct the appropriate two-way table, follow these steps:

1. Select **Statistics → Table Analysis** . . .
2. Select **Rater1** from the candidate list as the **Row** variable.
3. Select **Rater2** from the candidate list as the **Column** variable.
4. Select **count** from the candidate list as the **Cell Counts** variable.

Figure 9.24 displays the resulting dialog.
Request Measures of Agreement

To request measures of agreement, follow these steps:

1. Click on the Statistics button.
2. Select Measures of agreement.
3. Click OK.

Figure 9.25 displays the resulting Statistics dialog. Note that the chi-square tests of association and the measures of association are not appropriate for this type of table.
Figure 9.25. Statistics Dialog

Note that the Tables dialog specifications (see Figure 9.5) made previously remain in effect. Therefore, both frequencies and row percentages are produced for this analysis.

Click OK in the Table Analysis dialog to perform the analysis.

Review the Results

The frequency table is displayed in Figure 9.26. Note that most of the frequencies occur on the diagonals, which is what you would expect if there is any degree of agreement. However, there are several off-diagonal elements that represent nonagreement. In particular, there is one case of a student rated ‘good’ by Rater2 and ‘superior’ by Rater1. This might be unexpected.
Figure 9.26. Piano Agreement Frequency Table

Figure 9.27 contains the results for the measures of agreement.

Figure 9.27. Measures of Agreement
The simple kappa coefficient has a value of 0.4697, with a 95 percent confidence bounds of (0.1566, 0.7828). This suggests modest agreement of ratings. Note that the Bowker’s test of symmetry is also printed; this is a test that the probabilities represented by a square table satisfy symmetry.

When you have a $2 \times 2$ table, the measure of agreement produced is McNemar’s test.

References

