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Introduction
You can use the Report Engine to build different types of reports that are based on

SAS tables. You also can create reports based on queries that were created by using the
Query window or the SQL Editor window. (See Chapter 10, “Query and Reporting,” on
page 157 and Chapter 11, “Using the SQL Editor,” on page 205 for information on the
Query window and the SQL Editor window.) By using the Report Engine, you can
create lists; tables; graphics, including horizontal and vertical bar charts, pie charts,
and plots; and dynamic reports with drill-down features. You can easily change from
one report style to another using the Report Engine.

The “Using the Report Engine” chapter in Getting Started with the SAS System
Using SAS/ASSIST Software introduced the Report Engine and showed you how to
create a simple listing report and a drill-down report. This chapter explores the Report
Engine in more depth.
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Opening and Using the Report Engine Window
To open the Report Engine window, follow this selection path:

Tasks I Report Writing I Design Report I Report Engine

You also can open the Report Engine window by following this selection path:

Tasks I Data Management I Query I Query and Reporting

I Report Engine

The Report Engine window appears.

Display 5.1 Report Engine Window

When you open the Report Engine window, the last report that you created appears.
Select New from the File menu to clear the window. You can use New to clear the
Report Engine window at any time.

You use commands and make choices from selection lists to produce reports in the
Report Engine window. When you press TAB, your cursor moves to any field that
contains text that you can edit. The fields in the Report Engine window are described
in the following table. Type a ? in any field and press ENTER to list possible selections
for that field.
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Table 5.1 Fields in the Report Engine Window

Field Description

Data lists the name of the data source. Fill in the Type field before you select
the data source.

Type lists the type of data, such as a SAS table or query or a query on a DB2
table that you saved from the SQL Editor or the Query window. The
default value is SAS.

Report controls the type of report you want to generate. The default value is LIST.

To produce a report, first select the type of data in the Type field. You can select SAS
tables or views (type SAS), a query that was created by using the Query window (type
QUERY), or a query that was created by using the SQL Editor window (type SQL).
Queries do not contain any data but rather point to one or more tables.

After you select the type of report, type the name of the data source in the Data field.
If you type a ? in the Data field and press ENTER, the window that appears depends
on what is in the Type field:

� If the type is SQL or QUERY, the Open window appears showing your SQL or
QUERY entries. To sort the queries, select Sort By from the Edit menu and
select Name, Description, or Date to reorder the queries listed. Type S in the Cmd
field to select a query.

� If the type is SAS, the Select Table window appears. Select a table and select OK.

After you select the data source, type of data, and report, the Report Engine window
shows you the columns for the data you selected. For example, the following display
shows the columns for the AIRLINE.MARCH SAS table. See “Creating the AIRLINE
Sample Tables” on page 3 for more information on the AIRLINE sample tables.
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Display 5.2 Report Engine With AIRLINE.MARCH Table

To customize your report, you make modifications as described in the rest of this
chapter. To run the report, follow this selection path:

Run I Submit

The report appears in the Report Output window. To return to the Report Engine
window after viewing your report, follow this selection path:

File I Close

You can use the fields described in the following table to manipulate your report in
the Report Engine window.

Table 5.2 Fields in the Report Engine Window

Field Description

Row indicates the number of the first line of column information shown in the
window. If the table has more columns than will fit in the window, the
row number is in a different color, and you can type a new number in the
Row field to begin the display at the specified row number.

to indicates the column number of the last column shown in the window.

of indicates the total number of columns in the data source.

Cmd enables you to specify commands to manipulate the columns in the report.
Type a ? and press ENTER to list all of the commands, which are
described in Table 5.3 on page 65.
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Field Description

No indicates the order of the columns. (No is an abbreviation for Number).
You can change the column order by typing a new order number over the
old order number. To drop a column from the report, delete (or type
blanks over) the number in this field. The column label and length remain
in the window. See the D command in Table 5.3 on page 65 for an
alternate method of dropping columns from the report.

Order sorts the column data in the specified order. Type A to sort the column data
in ascending order. Type D to sort the column data in descending order.

Usage defines what a column represents. Usages change the appearance of the
report. You can type the usage into this field or type a ? for a list of the
possible usages. To produce reports other than lists, you must define at
least one usage such as GROUP, ACROSS, BREAK, or PAGE. See Table
5.4 on page 69 for a list and description of the usages.

Column Header indicates the column label. You can change the column label by typing
over the existing label. To reset the label to its original value, type an I in
the Cmd field to display the Column Information window. In the Column
Information window, select Reset and OK to return to the original
column label value.

Length indicates both the SAS format and data type of a specific column. You can
use any SAS format in this field. The format changes how the column
looks on your report. Type a ? to list SAS formats. A C to the right of the
column length indicates a character column, whereas an N indicates a
numeric column.

Modifying a Report Using the Cmd Field
You can use commands in the Report Engine window Cmd field to modify your report.

Type a ? in the Cmd field to list the commands described in the following table.

Table 5.3 Cmd Field Commands

Command Name Description

I Column
Information

displays detailed information about a column. See “Using the
Column Information Window” on page 71 for more information.

R Repeat repeats a column.
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Command Name Description

D Delete deletes a column from the report only. To restore deleted columns,
select Reset Columns from the Edit menu. When you delete a
column using D, all information for that column is removed from the
Report Engine window. See the No field in Table 5.2 on page 64 for
an alternate method of dropping columns from a report.

T Subtotal computes a subtotal on the column for each group defined by a
GROUP, PAGE, or BREAK usage. See Table 5.4 on page 69 for more
information on usages.

The following display shows the Report Engine window with the command to repeat
the No. of boarded passengers column. This display also shows that the number
in the No field for the No. of transfer passengers column has been erased to drop
the column from the report. After you press ENTER, repeated fields are indicated with
an R between the Cmd and No fields; dropped columns are moved to the bottom of the
list, and the other columns are renumbered. Any columns used to create subtotals are
indicated with a T.

Display 5.3 Using the Cmd Field

Modifying a Report’s Column Order, Headers, and Formats
You can use fields in the Report Engine window to modify the report’s column order,

headers, and formats as follows:
� Rearrange the report’s columns by changing the numbers of the No (Number) field.
� change the column headers by typing a new column header over the existing one.
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� Change the presentation of the column in your report by selecting a new format in
the Length field.

After you make your changes and press ENTER, the columns are reordered in the
Report Engine window and are renumbered to account for any dropped columns. Also,
the new formats are listed in the Length field.

Note: If the table has been sorted, you can set the User Profile option Column
Order to automatically put the BY column or columns at the top of the list in the
Report Engine window. See Appendix 2, “Customizing SAS/ASSIST Software,” on page
241 for information. 4

The following display shows the Report Engine window with the AIRLINE.MARCH
data file with the following modifications:

� The Weight of mail (kg), Weight of freight (kg), No. of transfer
passengers, and No. of disembarked pass. columns have been dropped from
the report by erasing their position numbers in the No field.

� The order of the Departure date and Flight number columns has been reversed.
� The column header for the No. of non-revenue pass. column has been

changed to No. of non-paying passengers..
� The format for the Departure date column has been changed to WEEKDATE17.

using the Column Information window (see “Using the Column Information
Window” on page 71 for details).

� The Departure Date column has been sorted in ascending order.
� The width for all columns has been changed to 10, except for the width for Flight

number, which has been changed to 6, and the Departure Date column, which
has been changed to 17 to accommodate its new format. Column widths do not
appear in the Report Engine window; you view and change the column width in
the Column Information window. See “Using the Column Information Window” on
page 71 for more information

� The title “Passenger Information for March” has been added by selecting Titles
from the Edit menu, and centered by selecting Page Layout from the Edit menu.
Title information does not appear on the Report Engine window.

� The repeated No. of boarded passengers column has been assigned a usage of
MAX, the column header has been changed to Max. No. of boarded
passengers, and the width has been changed to 10. For information on changing
usages, see “Modifying a Report with Usages” on page 69.

� The Departure date column has been assigned a usage of BREAK so that the
report breaks on each new date value.
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Display 5.4 Report Engine Window with Modifications to AIRLINE.MARCH Table

The following display shows the modified list report for the passenger data in the
AIRLINE.MARCH table. The report has been scrolled forward to show that the
maximum number of boarded passengers for a single flight for each day is given at the
bottom of the data for each day.
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Display 5.5 AIRLINE.MARCH Listing Report With Modifications

Modifying a Report with Usages

The values of Usage define what a column represents and change the appearance of
the report. The following table describes the different values of Usage. Note that SUM,
MEAN, MIN, MAX, AVG, COUNT, N, and NMISS are aggregate (or summary)
functions.

Table 5.4 Usages

Usage Description

PAGE creates a new page at each new column value. PAGE is used with the
ACROSS, GROUP, or BREAK usages. PAGE is valid only with a report of
type TABLE. With other types of reports, PAGE is used like a GROUP
usage. The corresponding SAS/GRAPH option for this usage is BY, which
creates a new page for each BY value.

GROUP groups data by the values in the column. The corresponding SAS/GRAPH
option for this usage is GROUP, which organizes bars and pies into groups
by different values of the GROUP variable.

ACROSS groups the report into subgroups across the report. The corresponding
SAS/GRAPH option for this usage is ACROSS, which is used to place
multiple pies "across" on a page and also is used by the LEGEND
statement.
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Usage Description

BREAK computes one summary for each column in a LIST report. With other
types of reports, BREAK is used like a GROUP usage.

SUM computes the sum of the values. The corresponding SAS/GRAPH option for
this usage is SUM, which prints the value of the sum statistic above bars.

MEAN computes the mean of the values. The corresponding SAS/GRAPH option
for this usage is MEAN, which is the value of the statistic for the variable
being used for calculations.

MIN computes the smallest value

MAX computes the largest value

AVG computes the average of the values (equal to mean)

COUNT computes the number of nonmissing values

N computes the number of nonmissing values

NMISS computes the number of missing values

The following display shows the AIRLINE.MARCH table in the Report Engine
window. All of the modifications made in the previous section are in effect; in addition,
the report has been further modified so that the report shows totals (SUM usage) for
the number of boarded and nonpaying passengers. A forward slash ( /) has been
inserted in the column header for the Max No. of boarded passengers so the
header breaks after the word Max.

Display 5.6 Report Engine Window with AIRLINE.MARCH Table and More Modifications
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The following display shows the passenger information report grouped by date with
the sum of the boarded passengers, the maximum number of boarded passengers, and
the sum of the nonpaying passengers. The report has been scrolled forward to show the
sums for the boarded and nonpaying columns.

Display 5.7 AIRLINE.MARCH Listing Report with More Modifications

Using the Column Information Window
To display information about a column, type I in the Cmd field for the desired column

and press ENTER. The following display shows the information for the Departure
Date column, as modified in the previous sections.
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Display 5.8 Column Information Window

When you press TAB in this window, your cursor moves to any field that you can
select or that contains text that you can edit to update the information in this window.
The information in this window varies according to the type of usage associated with a
column.

To reset the Report Header and Report Format to their original values, select
Reset from the Edit menu.

The fields on the Column information window are described in the following table.

Table 5.5 Fields in the Column Information Window

Field Description

Column indicates the column label stored with the source table.

Report Header indicates the column label to be used in the report.

Format indicates the column format stored with the source table.

Report format indicates the column format to be used in the report.

Column width indicates the width of the column in the report.

Type indicates the type of column data, C for character data, N for numeric data.

Sort order specifies how the column data are sorted in the report. A specifies that the
column data is sorted in ascending order in the report. D specifies that the
column data is sorted in descending order in the report.

Column Usage indicates the usage for the column. To produce reports other than lists,
you must define at least one of the following usages: GROUP, ACROSS,
BREAK, or PAGE. See Table 5.4 on page 69 for more information.
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Field Description

Report Width indicates the total width of the report.

Flow values specifies that character columns longer than the width indicated in the
Width field are flowed to multiple lines.

Subtotal writes a summary line (a line containing summaries of statistics and
computed variables) for each group defined by a BREAK, GROUP, or
PAGE usage. This parameter is available only on columns with a BREAK,
GROUP, or PAGE usage.

Display
subtotal text

prints the value of the group to the left of the subtotals. This parameter is
available only on columns with a BREAK, GROUP, or PAGE usage for
which the Subtotal parameter has been selected.

The following parameters are available only on columns with BREAK or PAGE
usages.

Table 5.6 Additional Fields in the Column Information Window for Columns with
BREAK or PAGE Usages

Field Description

Show as Column displays the value of each group in a column to the left of the
other columns. Rows displays the value of each group in a line above the
data for each group. Selecting Rows activates the other BREAK and
PAGE fields.

Position indicates where the group value appears, in spaces from the left margin.

Display text determines whether the group value appears in the report.

Text If Display text is checked, the text you supply in the Text field is
used instead of the group value. Leave this field blank to display the
group value.

Insert line determines whether to insert blank lines above and below the group value.

Choosing a Different Report Type
You can use the Report Engine window to create several types of reports. You can

change from one type of report to another in one of two ways:
� within the Report Engine window, type a new value in the Report field before

running the report. Alternatively, type ? in the field and press ENTER to list the
types of reports; then select the type of report.

� after you run one type of report, select a new type of report from the Run menu in
the Report Output window.

You can select the following types of reports:
� LIST creates a list report
� TABLE creates a tabular report
� DRILL creates a dynamic report
� HBAR creates a horizontal bar chart
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� VBAR creates a vertical bar chart
� PIE creates a pie chart
� PLOT creates an X by Y plot.

For any type of report other than LIST, you must assign a usage of BREAK, ACROSS,
GROUP, or PAGE to at least one column, which becomes the classification column for
tabular reports or the chart column for graphical reports.

To see the passenger information report as a table, type TABLE in the Report field in
the Report Engine window. Select Submit from the Run menu. The following display
shows the passenger information report as a table.

Display 5.9 Tabular Report Output

To see the passenger information report as a vertical bar chart, select Vertical Bar
from the Run menu of the Report Output window. Alternatively, type VBAR in the
Report Engine window Report field. The following display shows the passenger
information report as a vertical bar chart. Note that the format for the DATE column
has been changed to DATE9. to make more room for the bars.
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Display 5.10 Vertical Bar Chart Output

Inserting Date and Time Stamps in Titles and Footnotes
As discussed in the “Using the Report Engine” chapter of Getting Started with the

SAS System Using SAS/ASSIST Software, you can add titles and footnotes to your
report by selecting Titles or Footnotes from the Edit menu of the Report Engine
window. You can use the macros &CURDATE, &CURTIME, and &CURDT to
automatically generate the current date, the current time, or both the current date and
time, respectively, for your output.

In the Value field for each line of the title, type the text and the macro you want to
use. An example of an edited TITLES window is shown in the following display.
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Display 5.11 Edited TITLES Window

Select Close from the File menu. When prompted, select Yes to save the changes.
When you run your report, the &CURDT macro generates both the current date and
time automatically. You can assign a format to the macros &CURDATE, &CURTIME,
and &CURDT in your user profile by using the Date format, Time format, and Datetime
format options for a profile type of REPORT ENGINE. See “Setting User Profile
Options” on page 241 for additional information about user profile options.

You can also edit titles and footnotes by selecting Report Output Manager from the
View menu. In the Cmd field next to the report you want to change, type E and press
ENTER. The code for your report appears in the Edit window where you can edit your
titles and footnotes as well as the rest of your report.

Note: Any changes that you make to your report in the Edit window are saved only
if you save your output to an external file or a SAS file. When you save your report in
the Report Engine window, changes made in the Edit window are not saved with your
report. 4

Additional Report Engine Options
The Edit menu contains additional options that enable you to customize your report.

This section describes items on the Edit menu that are not discussed elsewhere in this
chapter.
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Grand Totals
The Grand Totals item enables you to display overall totals for the report. You can

display column grand totals or row grand totals.
Follow these directions to display column grand totals.
1 For LIST reports, specify a usage of BREAK, GROUP, or PAGE for a column. For

TABLE reports, specify a usage of GROUP for a column.
2 Specify a statistics usage (such as MIN, MAX, MEAN, and so on) on at least one

column. This statistic will be calculated on that column in each BREAK, GROUP,
or PAGE value and for the overall report.

3 Follow this selection path:

Edit I Grand Totals

The Grand Totals window appears.

Display 5.12 Grand Totals Window

4 Type some identifying text (for example, Overall) in the Column Total field.
Select Text if it is not already selected.

5 Select OK. Run the report.

To display row grand totals, follow the above directions, except use an ACROSS
usage instead of BREAK, PAGE, or GROUP. Also, use the Row Total field to enter your
identifying text.

Note: Sometimes the grand total identifying text does not appear in the report
output. Usually this happens because the line size is not large enough to accomodate
the text. To solve this problem, select Page Layout from the Edit menu and specify a
larger value for Line Size. 4
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Subset Data
The Subset Data item opens the Build a WHERE Clause to Subset Your Data,

enabling you to apply a WHERE clause to your data when creating your report. For
details on this window, see the “Report Writing” chapter in Getting Started with the
SAS System Using SAS/ASSIST Software.

Limit Output Rows
The Limit Output Rows item opens the Limit Number of Output Rows window,

enabling you to limit the report output to the number of rows you specify. The default is
MAX, or all rows.

Row Title Space
The Row Title Space item is used only for the TABLE report style. Selecting this

item opens a dialog box which enables you to set the width of the row title, that is, the
left column or columns which identify the contents of the row.

Saving Reports

Saving a Report to a SAS Catalog
To save Report Engine window selections for future use, select Save As from the

File menu in the Report Engine window. The Save As window appears.
Type a name and, optionally, a description for the report and the catalog where you

want to save the report. Select OK to save the report or Cancel to cancel the save. If
the report name exists, you are prompted to select OK again to write over the existing
report, or you can type a new name for the report. After you name the report, you can
use Save from the File menu to save the report again.

For a list of existing reports, type a ? in the Name field of the Save As window. You
can type S in the Cmd field to select a report from the resulting selection list. For a list
of available catalogs, type a ? in the Catalog field. Select the catalog from the
resulting selection list.

Report Engine window selections are saved as type REPORT.

Saving Report Output to a SAS Catalog
To save a report output to a SAS catalog for future use, select Save As from the File

menu in the Report Output window. The Save As window appears.
Type a name and optional description for the report output and the catalog where

you want to save the report output. Select OK to save the report output or Cancel to
cancel the save. If the report output name exists, you are prompted to type a new name
or to select OK again to write over the existing report output.

You can view a selection list of existing OUTPUT entries and catalogs in the same
manner as described in the previous section.
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Report output is saved as type OUTPUT. You can access your saved output using the
Result Manager or the Report Output Manager. Refer to Chapter 9, “Doing More with
Results,” on page 145 for additional information.

Saving a Report to an External File
Before you save your report to an external file, make sure that the value for the

Output window User Profile option is set to Report in your user profile. See Appendix
2, “Customizing SAS/ASSIST Software,” on page 241 for more information.

To save the report to an external file, follow this path from the Report Engine
Window or the Report Output Window:

View I Report Output Manager

The Report Output Manager window appears as shown in the following display.

Display 5.13 Report Output Manager Window

Type F (for File) in the Cmd field next to the report you want to save and press
ENTER. The Save Task to External File window appears as shown in the following
display.
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Display 5.14 Save Task to External File Window

In the Save file to field, type the name of the external file where you want to
store the report and select OK. Select Close from the File menu to return to the Report
Engine window.

Saving a Dynamic Report as a SAS Table
Dynamic (or drilldown) reports are described in detail in the “Using the Report

Engine” chapter of Getting Started with the SAS System Using SAS/ASSIST Software.
You can save the information for a column in a dynamic report to a SAS table or view.
For example, if you select Flight to see the column values for the aggregation level as
shown in the following display, you can save the data in the report to a SAS table or
view.
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Display 5.15 Dynamic Report With Flight Information

To save information from a dynamic report to a SAS table, follow these instructions:
1 Select Save As SAS Table... from the File menu. The Create SAS Table/View

window appears.
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Display 5.16 Create SAS Table/View Window

2 In the Name field, type the two-level name of the SAS table or view that you want
to create. If you omit the libname, the table is placed in the temporary WORK
library.

3 Select Table or View for the Type.
4 Select OK. The SAS Table/View Creation Status window appears, as shown in the

following display, indicating that the table or view was created.



Doing More with the Report Engine 4 Opening an Existing Report 83

Display 5.17 SAS Table/View Creation Status Window

5 Select View to browse the table or view that you just created. After you have
finished browsing the table or view, select Close from the File menu to return to
the SAS Table/View Creation Status window. Select Goback to return to the
Dynamic Report window.

Opening an Existing Report
To open an existing report from the Report Engine window, select Open from the

File menu. The Open window appears, as shown in the following display.
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Display 5.18 Open Window for Reports

You can type S in the Cmd field and press ENTER to select and open a report in the
Report Engine window. To sort the reports, select Sort By from the Edit menu and
select Name, Description, or Date to reorder the reports listed.

Selecting Other Data

In the Report Engine window, you can select new tables and queries and retain
modified column information. For example, you may have a query that is based on the
AIRLINE.MARCH data file. If you change the format for the Departure date column
from DATE7. to DATE9. for the report and then select another query with a Departure
date column, the new report also uses the DATE9. format.

To select another query or table, fill in the Data and Type fields as described in
“Opening and Using the Report Engine Window” on page 62.

Editing a Graph Interactively

If you create a graph, you can edit the graph interactively. From the Report Output
window, select Edit Report from the Edit menu to invoke the SAS/GRAPH software
interactive graphics editor, as shown in the following display. You must have
SAS/GRAPH software installed to edit a graph interactively. Refer to the online help for
this window for more information.
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Display 5.19 Editing a Graph Interactively

To return to the Report Output window, select End from the File menu.
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