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Introduction
The SAS System for OpenVMS operating environments features an X Window

System interface that is based on Motif. This interface uses the window manager on
your system to manage the windows on your display. Window managers govern the
placement, sizing, stacking, and appearance of windows, as well as their interaction
with the keyboard. All window managers perform the same basic functions, but they
differ in their style and in their advanced functions. The appearance of the SAS
interface depends partially on which window manager you use.

The basics of interacting with the SAS System are the same for all window
managers: opening pull-down and pop-up menus, moving windows, responding to dialog
boxes, dragging text, and so on. This chapter describes some of the dialog boxes and
features that are specific to the SAS System.

Many features of the SAS graphical interface are controlled by X resources. For
example, colors, window sizes, the appearance of the ToolBox, and key definitions are
all controlled through X resources. The following sections may refer to a specific
resource that controls a feature of the interface. Chapter 4, “Customizing the SAS
Windowing Environment,” on page 71 provides general information on resources, such
as how to specify resources, and describes all of the resources that you can use to
customize the interface.
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Note: The About SAS System dialog box displays version information about the SAS
System, your operating environment, and Motif. You can display the About SAS System
dialog box by selecting About SAS System from the Help menu. 4

Using Function Keys
Function keys provide quick access to commands. They allow you to issue

commands, insert text strings, and insert commands in programs. Function key
definitions may be different on different terminals. To display your function key
definitions, open the KEYS (DMKEYS) window (see Display 3.1 on page 59) from the
Tools menu by selecting Options, and then selecting Keys.
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Display 3.1 KEYS (DMKEYS) Window

To view a single key definition without bringing up the KEYS window, use the
KEYDEF command and specify the key definition that you want to view. For example,
the following command displays the definition for key F4:

keydef f4

For information about customizing key definitions, see “Customizing Key Definitions”
on page 89. For more information about the KEYS window and the KEYDEF command,
refer to the SAS online Help system.
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Using the SAS ToolBox
The SAS ToolBox has two parts:
� A command window that enables you to quickly enter any command.
� A toolbar that contains several tool icons.

You can use the command window to enter commands in the active SAS window. The
name of the active window is displayed in the title bar of the ToolBox. The toolbar
allows you to associate icons with commands.

You can define multiple toolboxes and switch between them, and you can define
toolboxes for specific windows or applications, such as SAS/AF applications. By default,
the toolbar and the command window are joined and are automatically displayed when
the SAS System initializes unless

� you executed your SAS job in a nonwindowing environment mode.
� the SAS.defaultToolBox resource or SAS.defaultCommandWindow resource is

set to False. The default is True. For more information about the X resources that
control the ToolBox, see “Specifying Toolbox X Resources” on page 83.

� you deselect Display tools window, Display command window, or Combine
windows from the ToolBox tab in the Preferences dialog box.

Display 3.2 on page 60 shows the command window and the toolbar in their default
configuration.

Display 3.2 SAS ToolBox

When the command window and the toolbar are combined, you can open both of
them by doing one of the following:

� issuing the COMMAND WINDOW command.
� from the Tools menu in the active window, selecting Options, and then selecting

ToolBox.
� From the ToolBox tab in the Preferences dialog box, select Display tools

window, Display command window, and Combine windows. (See “Modifying
the Toolbox and Command Window Settings” on page 80.)

� issuing the TOOLLOAD command. For more information, see the command
“TOOLLOAD” on page 233.

You can close both the command window and the toolbar by doing one of the following:
� double-clicking on the window menu button in the upper-left corner of the ToolBox.
� from the ToolBox window menu, select Close.
� entering the TOOLCLOSE command, as described in “TOOLCLOSE” on page 232.
� from the Tools menu, selecting Options and deselecting ToolBox.

Using the Command Window
You can open only the command window portion of the ToolBox by deselecting

Combine windows from the ToolBox tab in the Preferences dialog box and doing one of
the following:
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� selecting Display command window in the Preferences dialog box.

� issuing the COMMAND WINDOW command.

To issue a command from the command window, click in the command window, type
in the command, and then press ENTER or click on the check mark. The command is
submitted in the active SAS window.

You can use the up and down arrows to scroll through previously entered commands,
or you can select a previous command from the drop-down list. Use the middle mouse
button (MB2) to select and execute a command from the list. If you use the left mouse
button (MB1), the command is selected, but you must then press ENTER or click on the
check mark to submit the command.

Using the Toolbar
You can open only the toolbar portion of the ToolBox by deselecting Combine

windows from the ToolBox tab in the Preferences dialog box and doing one the following:

� selecting Display tools window in the Preferences dialog box.

� from the Tools menu, selecting Options, and then selecting ToolBox.

� issuing the TOOLLOAD command, as described in “TOOLLOAD” on page 233.

If you invoke an application that does not have an associated PMENU entry, the
default toolbox is displayed for that application. If you then customize the toolbox for
that application, the customized toolbox is stored in
SASUSER.PROFILE.DEFAULT.TOOLBOX, where <DEFAULT> is the same entry
name as the PMENU entry for the window or application.

You can customize the default toolbox, create multiple toolboxes and switch between
them, and create application-specific toolboxes that are automatically loaded when the
application is loaded. Only one toolbox is displayed at a time, and the tools in the
toolbox change as you move between applications. For more information about
customizing your toolboxes, see “Customizing Toolboxes and Toolsets” on page 83.

You can close only the toolbar by deselecting Combine windows from the ToolBox
tab in the Preferences dialog box and by doing one of the following:

� deselecting Display tools window in the Preferences dialog box.

� issuing the TOOLCLOSE command, as described in “TOOLCLOSE” on page 232.

� from the Tools menu, selecting Options and deselecting ToolBox.

Using the Tool Icons
If you place the cursor over an icon for the amount of time specified by the

SAS.toolBoxTipDelay resource, a pop-up displays text that describes the command
for that icon.

Clicking on a tool icon in a toolbox executes the command or commands associated
with that icon.

Opening Files

The Open dialog box (see Display 3.3 on page 62) enables you to select a file to read
into the active window. To access this dialog box, issue the DLGOPEN command in the
command window, or select Open from the File menu in the active window.
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The Open dialog box displays files and directories as a graphical hierarchy. You will
not see directories that you do not have read permission for. Double-click on a directory
to list the files it contains. Select the desired file.

You can display a list of possible file filters by selecting the down arrow next to the
File Type field. Click on a file filter to select it.

Display 3.3 Open Dialog Box

The following is an explanation of the settings:

Enter directory, filename, or filter: field
is where you can type in the name of the directory, file, or file filter (file type) that
you want to open.

Directories:
contains the names of the directories specified in the Filter field.

Files:
contains the files in the selected directory that match the file filter specified.

File type:
allows you to select the type or types of files to be shown in the Files:list box.
You can display a list of possible file filters by selecting the down arrow next to the
field. Click on a file filter to select it.

The Open dialog box displays nonreadable directories with a different icon.
To display a list of all the files in a directory, enter the asterisk (*) wild card in the

Filter field or select All Files;* from the list of file types.
The directory listed under the Filter field is the currently selected directory. You can

change this directory either by selecting a name from the Directories: list or by
typing the new name directly into the field.

You can specify the initial file filter in the File type: field by assigning a value to
the SAS.pattern resource. However, the Open dialog box retains its file filter between
invocations, so the SAS.pattern resource applies only to the first invocation of the
Open dialog box. You can also use the SAS.directory resource to specify the directory
that you want when you first invoked the Open dialog box.

Click on OK when you have finished making your selection. Click on Cancel to
close the Open dialog box without selecting a new file.
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For more information about specifying SAS resources, see “Using X Resources to
Customize the Motif Interface” on page 74.

Changing Your Current Working Directory

The working directory is the operating system directory where you invoke the SAS
System. By default, the SAS System uses the current directory as the working directory
when you begin your SAS session.

You can change the current working directory during your SAS session. You can use
the Change Working Directory dialog box to select a new directory, or you can use the X
command, the X statement, the CALL SYSTEM routine, or the %SYSEXEC macro
statement to issue the change directory ( set default) command.

The Change Working Directory dialog box (Display 3.4 on page 63) works exactly the
same as the Open dialog box (Display 3.3 on page 62), except that you can select only a
directory (not a file) from the list. To access this dialog box, issue the DLGCDIR
command in the command window, or from the Tools menu in the active window, select
Options and then select Change directory.

Display 3.4 Change Working Directory Dialog Box

The following is an explanation of the settings:

Enter directory or filter: field
is where you can type in the name of the directory or file filter that you want to
open.

Directories:
contains the names of the directories specified in the Filter field.

Files:
contains the files in the selected directory that match the file filter specified.
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File type:
allows you to select the type or types of files to be shown in the Files: list box.
You can display a list of possible file filters by selecting the down arrow next to the
field. Click on a file filter to select it.

Searching for Character Strings

The Find dialog box allows you to search for character strings in any active SAS text
editor windows such as the Program Editor, the SCL editor, or the Notepad.

To search for a character string, open the Find dialog box (Display 3.5 on page 64), by
issuing the DLGFIND command in the command window, or selecting Find from the
Edit menu in the active window. When the Find dialog box opens, the name of the
active window follows the name of the dialog box (for example, Find...:Program Editor).

Display 3.5 Find Dialog Box

The following is an explanation of the settings:

Find: field
allows you to type in the character string that you want to find.

Match Case
tells the search to match the uppercase and lowercase characters exactly as you
typed them.

Match Word
searches for the specified string delimited by spaces, end-of-line characters, or
end-of-file characters.

Previous
searches for the specified string from the current cursor position toward the
beginning of the file.

Next
searches for the specified string from the current cursor position toward the end of
the file.

To find a character string, type the string in the Find: field, tailor your search by
selecting or deselecting the appropriate check boxes, and click on Find . Click on
Cancel to cancel your choices and close the Find dialog box.
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Replacing Character Strings

The Replace dialog box allow you to search for and replace character strings in any
active SAS text editor windows such at the Program Editor, the SCL editor, or the
Notepad.

To replace one character string with another, open the Replace dialog box (Display
3.6 on page 65), by issuing the DLGREPLACE command in the command window, or
selecting Replace from the Edit menu in the active window. When the Replace dialog
box opens, the name of the active window follows the name of the dialog box (for
example, Replace...:Program Editor).

Display 3.6 Replace Dialog Box

The following is an explanation of the settings:

Find: field
allows you to type in the character string that you want to find.

Replace: field
allows you to type in the character string that you want to use as the replacement.

Match Case
tells the search to match the uppercase and lowercase characters exactly as you
typed them.

Match Word
searches for the specified string delimited by spaces, end-of-line characters, or
end-of-file characters.

Previous
searches for the specified string from the current cursor position toward the
beginning of the file.

Next
searches for the specified string from the current cursor position toward the end of
the file.

To find a character string, type the string in the Find: field, then click on Find .
To replace a character string, type the string in the Find: field and type its

replacement in the Replace: field. Click on Replace . To change every occurrence of
the string to its replacement string, click on Replace All .

Click on Cancel to cancel your choices and close the Replace dialog box.
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Sending Mail from within Your SAS Session

The Send Mail dialog box (Display 3.7 on page 66) allows you to send e-mail without
leaving your current SAS session.

Display 3.7 Send Mail Dialog Box

The dialog box automatically grabs the contents of the active SAS text window, so
you can include the window contents in your message quickly and easily. If you do not
want to include the contents of the active SAS editor window in your message, select
Clear All from the Edit menu before opening the Send Mail dialog box.

To open the Send Mail dialog box, select Send Mail... from the File menu.
To send e-mail, perform the following steps:

� Enter the ID(s) of the e-mail recipients in the To: and CC: fields. Separate
multiple addresses with either blanks or commas.

� Edit the entry in the Subject: field as needed.

� Type your message in the message area or edit the contents grabbed from the
active SAS text window.

� Click on Send .

To cancel a message, click on Cancel .

Iconizing Windows

Under OpenVMS, you can iconize only top-level SAS windows and windowing
environment containers. You cannot iconize groups of windows.
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Using the Menus
Under OpenVMS, the pull-down menu (PMENU) facility is turned on by default.

Also, some of the menus are customized, omitting items that are not applicable.
You can use the PMENU procedure under OpenVMS to create customized menus.

Some aspects of this procedure are specific to OpenVMS. For more information about
the PMENU procedure, see “PMENU” on page 346 and SAS Procedures Guide.

Using the Mouse
You can use the left mouse button (MB1) to make a mark, and the middle mouse

button (MB2) to paste the mark into a SAS System window. Although the right mouse
button (MB3) is not used in cut-and-paste operations, various procedures use MB3 to
display a pop-up menu.

SAS Mouse Pointer Shapes
When you use the SAS windowing interface under OpenVMS, you see several mouse

pointer shapes. If the mouse pointer has its standard shape (usually an arrow), the
SAS System is ready to receive your input.

Besides the standard shape, two other mouse pointer shapes are common:

watch (or clock) cursor
indicates that you must wait. The SAS System is performing other tasks and is
not ready to accept your input.

dash inside a circle
indicates that the pointer is in an inactive window. User interaction with this
window is temporarily disabled.

SAS Interface to the TPU Editor
The TPU command (or its aliases, HOSTEDIT or HED) enables you to use the

OpenVMS Text Processing Utility (TPU) editor for editing instead of the default SAS
Text Editor. For additional details about the TPU command, see “TPU” on page 234.

Using Special Character Attributes
SAS software enables you to set the color and highlight attributes of text in some

windows. For example, in the Notepad window or in your SAS/AF or SAS/FSP
applications, you can turn on character underlining or reverse video to highlight a title.
Character attributes are listed in Table 3.1 on page 68. To select an attribute, press and
hold the Modifier 1 key on your keyboard (usually labeled “Meta,” “Alt,” “Hyphen,” or
“Extend char”). Then, press the attribute key (for example, 1).
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Table 3.1 Selector Characters for Character Attributes

Selector Character Function

0 Turns off all attributes.

1 Turns on bold.

2 Turns on underlining.

3 Turns on reverse video.

4 Turns on blinking.

A Sets color to gray.

B Sets color to blue.

C Sets color to cyan.

G Sets color to green.

K Sets color to black.

M Sets color to magenta.

N Sets color to brown.

O Sets color to orange.

P Sets color to pink.

R Sets color to red.

W Sets color to white.

Y Sets color to yellow.

Alternatively, you can use the COLOR command to combine several of these steps in
one command. For more information about the COLOR command, see “COLOR” on
page 221.

Getting Help

In the SAS windowing environment, extensive online help is available. You can get
information in an abbreviated form or in a more complete form. For the shorter form,
select SAS System Help from the Help menu in the active window. Various topics are
available from this point.

To access the OpenVMS documentation online, from the Help menu in the active
window, select Books and Training, and then select SAS OnlineDoc. You can open
various SAS documentation from this point.

Note: The SAS online documentation must also be installed for SAS OnlineDoc to
function correctly. 4

Setting Your System for Help and Online Documentation
In Version 8, the SAS online Help system and other online documentation can be

displayed only by using an HTML browser. You have to specify the browser and its
location before you can use it.
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From the Tools menu in the active window, select Options, and then select
Preferences to open the Preferences dialog box. Then select the DMS tab. In the
Help and Documentation Browser field, specify the Netscape browser and point to
the location of its executable file.
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